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1 Installing Weintek Built-in CODESYS

L_I WE!NTEK

Installing Weintek Built-in CODESYS allows users to easily create a cMT3090 CODESYS
project in CODESYS software. Please find the Package file we prepared and follow

these steps for quick installation.

1.

2.

3.

4.

Firstly, get a working CODESYS Package file.

gt

weintek_2018012
4 package

On your PC, right-click the mouse button and select [Open with CODESYS

Package Manager].

Open with CODESYS Package Manager
Open with...

Share with 4

Restore previous versions

Send to »
Cut

Copy

Create shertcut
Delete

Rename

Properties

Select Complete Setup or Typical Setup (you may select any of these setup

types since the components used by Weintek Built-in CODESYS exist in both

types.)

£ Installation - Choose Setup Type

Weintek Built-in CODESYS [2018.1.24]
Please selectthe typeof setup youwould liketo perform.

@ Complete setup
All package components will be installed.

) Typical setup
The most commonly used package components will be installed.

Cancel MNext =

sl

[y

Click [Next] when seeing the following message.
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&7 Installation - Setup Completed @
Weintek Built-in CODESYS [2018.1.24] m
WEINTEX

The package has been successfully installed. Click Finish to exit the wizard or Next to see
the summary.

[ Mext> | [ Fnish |

5.  Theinstalled component will be shown in the installation summary.

&7 Installation - Summary @
Weintek Built-in CODESYS [2018.1.24]
Installation summary m

Summary:

= Device description (1)

Component/DeviceDescription/Weintek-Cortex-embedded.devdesc.xml: Iter

4 m 2
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2 Creating cMT3090 CODESYS Project

1.  Launch CODESYS V3.5 and click [File] » [New Project], and then select

[Standard project]. Enter the project name in Name filed, browse for the
location, and then click [OK] to leave.

=] Mew Project @
Categories: Templates:
-+ Libraries e -
3 Projects [ B i 'E 'E

Empty project  HMI project Standard Standard

project project w...
o

Standard
project w...

A project containing one device, one application, and an empty implementation for PLC_FPRG

Name: cMT3050c

Location:  C:\Usersiuser\Documents - E]

2. CODYSYS software provides 6 languages that can be selected in [PLC_PRG
in:] drop-down list as shown below.
Standard Project \EI
You are about to create a new standard project. This wizard will create the following
— objects within this project:
[E
- One programmable device as specified below
- Aprogram PLC_PRG in thelanguage specified below
- A cyclic task which calls PLC_PRG
- A reference to the newest version of the Standard library currently installed.
Device: | Weintek Builtin CODESYS (Weintek Labs., Inc.) -
PLC_PRG in: |Structured Text (5T) -]
Continuous Function Chart (CFC)
Continuous Function Chart (CFC) - page-oriented
Function Block Diagram (FED)
Ladder Logic Diagram (LD)
Sei uential Function Chart SFC:II
Structured Text (ST,
3. Double-click on Device (Weintek Built-in CODESYS) to open the settings

window.
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Devices - 0 X
=5 cMT3090C B3
= - [ |pevice (Weintek Built-in CODESYS) |
=-El] PLC Logic
=-{C} Application
m Library Manager
PLC_PRG (FRG)
= @ Task Configuration
= @ MairTask
H PLC_PRG
[ pevice x
Communication Settings Scan Network... | Gateway - Device -
Applications
Backup and Restore
Files . *
Gateway .

Log

ateway-1| - VB -
PLC Settings IP-Address:

localhost
PLC shell

Pork

Users and Groups

Task Deployment

Status

Information

1217

4. Open Scan Network tab, CODESYS software will start searching for the

CODESYS devices on the same network. Select the desired device and then

click [OK] to leave. The project will connect the selected device.

Select Device

Select the network path to the controller:

= .%. Gateway-1(scanning...)
cMT-00 [026A]
cMT-8B28-ted [0205]
cMT-DD6A [0241]
cMT-DDET [0234]
CMT-EBCE [0243]
cMT-EGCS [025E]

SIS

Device Name:
Gateway-1

Driver:
TCR/IP

IP-Address:
localhost

Port:
1217

Cancel
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3 Connecting iR-COP

1. Right-click on Device (Weintek Built-in CODESYS) and then select [Add
Device].
2. Select [Canbus] » [Canbus], and then select [Add Device].

[1J Add Device (===

Name: CANbus
Action:
@ Append device (7) Update device

Enter a string for a fulltext search in all devices...  Vendor: | <Al vendars> ']

-

Mame Vender Version Description

= m Figldbuszes
= AN CANbus
ﬁ 35 - Smart Software Solutions GmbH 3.5.10.0 MNeeded for all fieldbusse|
m MetX Canbus 35 - Smart Software Solutions GmbH 3.5.10.0 CANbus on a netX device
+ ol EtherCAT
+ - EB Ethernet Adapter

4| m | 3

3. CANbus (CANbus) can be found in Devices tree.

Devices ~ 0 X
=[5 eMTI090c (=]
= ﬂj Device (Weintek Built4n CODESYS)
=B pLC Logic
=1} Application

m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
=gk MainTask
& pic PR

[ canbus {CANbus)

4. Double-click on CANbus (CANbus) with the current window opened in
Devices tree, or right-click on CANbus (CANbus) and then select [Add

Device].
5.  Click [Fieldbusses] » [CANopen] » [CANopen Manager] » [CANopen
Manager], and then select [Add Device].

(1] Add Device [
Name: CAMopen_Manager
Action:
@ Append device () Insert device () Update device
Enter a string for a fullkext search in all devices...  Vendor: | <all vendors: -
Mame Vendor Version D =

= m Fieldbusses
= Cifl CANopen
= &ifl CANopenManager

m |CANopen_Manager 35 - Smart Software Solutions GmbH 3.5.10.0 ca
m CAMopen_Manager_FDT 35 - Smart Software Solutions GmbH 3.5.7.20 c
ﬁi CAMopen_Manager_SIL2 35 - Smart Software Solutions GrbH 3.5.10.0 ce_
e | - - . .

1 1 | 3
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6. Double-click on CANopen_Manager with the current window opened in

Devices tree or right-click on CANopen_Manager and then click [Add

Device].

7.  Click [Fieldbusses] » [CANopen] » [Remote Device], find iR-COP and then

select [Add Device].

[ Add Device (===
Name: iR_COP

Action:

@ Append device () Insert device () Update device

Enter a string for a fulltext search in all devices... ~ Vendor: | weintek Labs., Inc. -
Mame Vendor Version Descriptic
= ﬂj Fieldbusses

= Gifl CANopen
=€l Remote Device
m iR-COP Weintek Labs., Inc. Revision=16#00000001, FileVersion=1.1 Imported f

1 m b

8. Double click on CANbus (CANbus) in Devices tree to open the settings

window. Please select the correct baud rate for iR-COP in General tab.

& cMT3080c.project” - CODESYS

File Edit Wew Project Build ©Online Debug Tools Window Help
e d& # % OB | of X
Devices r 1 x (1) cambus x| [ iR_cop
=5 eMTI00C
= m Device {(Weintek Built-n CODESYS) General
i General
= El] PLC Logic
=} Application CANbus 1/0 Mapping Network:
m Library Manager
Status Baudrate (bitfs):

PLC_PRG (PRG)
= @ Task Configuration
= §8 MainTask

& PLC_PRG
=| @ canbus (CANbus)

= ﬂ CANopen_Manager (CAMopen_Manager]
(@ ®_cor (rcor)

Information

4 N 2

: f
52 Devices | B® Modules

9. Create CANopen variables in PLC_PRG, for example:

FROGRAM FLC_FRG

z VAR

3 x0 BOOL;
4 xl BOOL;
& END VAR

1

[E= N (=3

0 -

250000 -

10. Double click on iR_Cop in Devices tree to open the settings window. Select

related variables in CANopen I/0 Mapping tab.
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General Find Filter Show all - |
s Variable Mapping  Channel Address Type Unit  Description Il
=" DO byte 1 %GB0 USINT L
SDOs "% Application.PLC_PRG.x0 ] BitD S%E%e-5  BOOL [
"§ Application.PLC_PRG.x1 " Bit1 KOt BOOL MW
CANopen If0 Mapping K@ Bit2 %QX0.2 BOOL
] Bit3 %L0X0.3 BOOL
Status ] Bit4 QX0 4 BOOL
"% Bit5 %QX0.5  BOOL
Information L™ Bits %4QX0.6 BOOL
"% Bit7 %QX0.7  BOOL
+- "y DO byte 2 %QB1 USINT
- l +- T DO byte 3 %0B2 USINT i
.

11. When finished, click [Online] » [Login] to download the project to
cMT3090.
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4 Connecting iR-ETN
1. Right-click on Device (Weintek Built-in CODESYS) and then select [Add

Device].
2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device].

[J Add Device (=23

Name: Ethernet

Action:
@ Append device (0) Update device

Enter a string for & fulltext search in all devices.,.  Vendor: | <all vendorss> -

Mame Vendor Version Description

= ﬂ'i Fieldbusses
+- AN CANbus
+ s EtherCAT
= - BB Ethernet Adapter
m Ethernet 35 - Smart Software Solutions GmbH 3.5.10.0 Ethernet Link.

+ - = EtherNet/TP il

m

3. Ethernet (Ethernet) can be found in Devices tree.

Devices - o X
=5 oMTI0%0 RETN (=]
= ﬁ |Device {Weintek Built-n CODESYS)
=2l PLC Logic

=} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MainTask
&1 pLC_PRG
] Ethernet (Ethernet)

4. Double-click on Ethernet with the current window opened in Devices tree
or right-click on Ethernet and then select [Add Device].

5. Click [Fieldbusses] » [Modbus] » [Modbus TCP Master] » [Modbus TCP
Master], and then select [Add Device].

[ Add Device [==3a]

Name: Maodbus_TCP_Master

Action:

@ Append device () Insert device (C) Update device

Enter a string for a fulltext searchin all devices... = Vendor: | <all vendors> -
Mame WVender Wersion Description *

= ﬂj Fieldbusses
+ - = EtherMet/IP
= Wil Modbus
= Wil Modbus TCP Master

m Modbus TCP Master 35 - Smart Software Solutions GmbH 3.5.10.0 A device thal—

+ - Wil ModbusTCP Slave Device -

m

6. Double-click on Modbus TCP Master with the current window opened in

Devices tree or right-click on Modbus TCP Master and then click [Add
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Device].
7.  Click [Fieldbusses] » [Modbus] » [Modbus TCP Slave] » [Modbus TCP Slave],
and then select [Add Device].

ﬁ

Name: Modbus_TCP_Slave

Action:

@ Append device (7) Insert device Flug device () Update device

Enter a string for & fulltext search in all devices.,,  Vendor: | <all vendors> -
Name Vendor Version Description
-ﬁ Fieldbusses

= iil§ Modbus
=¥ Modbus TCP Slave
i | 35 - Smart Software Solutions GmbH ~ 3.5.10.0 A generic Modbus ¢

8. Double click on Ethernet in the Devices tree, enter cMT3090’s IP address in

General tab, and then select [Change Operating System Settings].

(@ Device /Vm Ethernet x]/m Modbus_TCP_Master ] -
=5 oMTI090_R-ETN
=- m Device (Weintek Builtin CODESYS) General
—@l] PLC Logic Interface: ethd E]
—O Application Status

i r (71 Use Operating System Settings
m Library Manager -
PLC_PRG (PRG) Ethernet Device I/0 Mapping @ Change Operating System Settings

‘@ Task Configuration ; )
=¥ MainTask Information IP Address 192 . 1688 . 2 . 1%
45 pLC_PRG L subnet Mask 255 . 255 . 252 . O

-E---ﬂj|Eﬂ1emet(Eﬁ'1emet) ——
= m Modbus_TCP_Master (Modbus TCP Mastg

----- m Modbus_TCP_Slave (Modbus TCP Slg

— Default Gateway 192 . 188 . 1 . 254

I | 3

<
22 Devices | Modules
9.  When cMT3090 is already connected, go to General tab and click the [...]

button near Interface field and select ethO.

ﬁ

Interfaces:

Name Diescription IP Address

Io 127.001
wvietl 10.2552552
IP Address 192 168 . 2 . 73
Subnet Mask 255 355 .352 .0

Diefanlt Gateway 192 188 . 1 . 254
MAC Lddress 00.0C:26:.0FE3 3B

[ ok [ Comeel |

10. Select Modbus_TCP_Slave in the Devices tree and then go to General tab
to set up IR-ETN’s IP address and Unit ID.
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Devices > 1 x [ Modbus_TCP_Slave x -
=-F) oMT3090_R-ETV
= m Device (Weintek Builtsn CODESYS) General Modbus-TCP
=B PLC Logic
=1} Application Modbus Slave Channel Slave IP Address: 192 . 188 . 2 . 144
:lf;iLYRZB(I;:QGT Madbus Slave Init Unit-I0 [1.247] !
= @ Task Configuration Response Timeout (ms) 1000
=8 MainTask ModbusTCPSlave Parameters Port w02
@ PLC_PRG ModbusTCPSlave If0 Mapping
= m Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCP Maste Status
m |Modbus_TCP_SIave (Modbus TCP Sla
q| = . Information

- - 4 [T G
22 Devices | F Modules

11. Open [Modbus Slave Channel] tab and create Modbus Variable.

ModbusChannel @

Channel

Name Read 0x-0

Access Type ’Read Discrete Inputs (Function Code 2) -
Trigger [Cydic V] Cycle Time (ms) 100
Comment

READ Register

Offset 0x0000 -
Length 1

Error Handling Keep last Value A

WRITE Register
Offset 0x0000

Length 0

oK ][ Cancel ]

ModbusChannel @

Channel

Name Write Ox-0

Access Type ’Wrihe Multiple Coils (Function Code 15) -
Trigger [Cydic V] Cycle Time (ms) 100
Comment

READ Register

Offset

Length 1

Error Handling Keep last Value

WRITE Register
Offset 0 -

Length 1

[ oK ][ Cancel ]

12. Open PLC_PRG in Devices tree, create variable and set Bool as data type.

10
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FROGRAM FLC_FRG

1
[

VAR
E] read: BOOL:
4 write: bool;
L END VAR

13. Open Modbus_TCP_Slave in Devices tree and then go to
[Modbus_TCPSlave 1/0 Mapping] tab to set up iR-ETN’s IP address and Unit

ID.
Variable Mapping  Channel Address Type Unit  Description
= Read 0x-0 %%IBO ARRAY [0..0] OF BYTE Read Discrete Inputs
= Read 0x-0[0] %eIB0 BYTE Read Discrete Inputs
“p Application. PLC_PRG.read "% Bit0 BeheaS BOOL 0x0000
=T Write Ox-0 %0B0 ARRAY [0..0] OF BYTE Write Multiple Coils
=" Write 0x-0[0] %QB0 BYTE Write Multiple Coils
"% Application.PLC_PRG.write " Bitd SLGWE8:8  BOOL 00000

14. When finished, click [Online] » [Login] to download the project to
cMT3090.

11
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5 EasyBuilder Connection Settings

5.1 Exporting Tag

1. Right-click on Application in Devices tree and then select [Add Object] »
[Symbol Configuration], use defaults.

Add Symbeol Configuration @
B8 Createaremoteaccess symbal configuration.

Name:

Symbaol Configuration

[] Include Comments in XML
[C] Support OPC LA Features

Client side data layout
() Compatibility Layout
@ Optimized Layout

[ Add ][ Cancel ]

2. Find PLC_PRG, select the variables to be exported, and then click [Build].

Changed symbol configuration will be transferred with the next download or online change

Symbols Access Rights Maximal  Attribute  Type Members  Comment
+-[7] [5] constants

+ |:| IoConfig_Globals

= PLC_PRG

% read "y " BOOL
# write " " BOOL
+-[] {} BPLog

+-[C] {} lecvarAccessLibrary
#-[C] {} IoStandard
+-[C] {} _35_LICENSE

3. Select [Build] » [General code], the *.xml file can be found in the directory
of the project.

12
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5.2 Configuring EasyBuilder
1. Create a project and select Weintek Built-in CODESYS in the device list.

| Estended Memory |  CellularDatsNetwork | TimeSyme/DST | eMasil | Recipes
Device | Madel I enersl I System Setting I Remote I Security
Device list : Wl hat's mor TP
Mo. Mame Laocation Address type Int
= LocalHMI | Local HMI Local cMT3090 (768 x 1024) -
W ocalPLC4  |Weintek Built-in CODESYS Weintek Buili-in CODESYS |- |

2. Open Tag Manager and click (4 , and then click [Import Tag] to import

the *.xml file.

Variable List
Name : I‘I’agTabIe Find : [Q. ]
O X v ¢ M D AEAOD

Verifying Tags with device...

Symbols | Data Import Tags...

Tag

3. The CODESYS tags can now be found in Tag Manager.

13
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My Application Variable List

=2- A_pplicatiun Mame : |TagTabIe Find : [Q
=8 T._ags
- TagTable

o X » ¢

Symbols Data Type| Scan Rate ()

EF Tag
— Application.PLC_PRG.read  BOOL Default
— Application.PLC_PRG.write| BOOL Default

Import Status

Imported tag information successfully.
0 warningys)

14
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6 Removing Weintek Built-in CODESYS

1. Click [Tools] » [Packages Manager].
2. Find Weintek Built-in CODESYS and then click [Uninstall].

(7 Package Manager IEI

Currently installed packages:

Sort by: |Mame v] [ Install... ]
Mame Version Installation date Update info Licenze info Uninstall...
& CODESYS SoftMotion 4.1.1.0 2017/11/27 Free version 4.3, 1.0 available! Mo license reg

.’-;'_| Weintek Builtin CODESYS 2018.1.29 2018/2f2 License info no

Updates

Search updates

3. Click [Next] when seeing the window below.

¥ Uninstallation (=25
Weintek Built-in CODESYS [2018.1.24]
Uninstallation m
WEINTEX
The package will be removed fromyour system. Click Next to continue.
ot
4. Removing the program.
£ Uninstallation ez
Weintek Built-in CODESYS [2018.1.24]
Pleasewaitwhile the packageisbeing uninstalled. m
WEINTEX

Initializing...

15
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5. Click [Finish].

£ Uninstallation @
Weintek Built-in CODESYS [2018.1.24] EI
WEINTEX

The package has been successfully removed from your system. Click Finish to exit the
wizard.
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